Sims 3 Packs not showing as installed – workaround

ts3-site-button

If your installed Expansion and Stuff Packs aren’t showing as installed in your Applications > Electronic Arts > The Sims 3 folder and you are receiving the Unknown Error message then you need to follow the instructions below to get your packs working properly. This is related to, but not the same as, the other Unknown Error message whereby files need copying from one EP to the other. You will also need to probably follow those instructions in order to complete the installation successfully. Get yourself comfortable before doing this, depending on how many EPs and SPs you have it may take a while!

Symptom:
You have just downloaded and installed an Expansion or Stuff pack through Origin but the pack is not showing up in your Applications > Electronic Arts > The Sims 3 folder. If you try to launch the game from another EP/SP or the base game you get the Unknown Error message.

Affected Expansion and Stuff Packs:
Ambitions, Fast Lane, Late Night, Outdoor Living

Affected Macs:
All those downloading and installing the digital versions of the affected packs through Origin.

Cause:
During the installation process the add on pack alias (shortcut) is not being added to the base game Application folder so the game cannot find it.

Solution:

  1. Navigate to your base game in Applications > Electronic Arts > The Sims 3, right click on it and then select Show Package Contents.
  2. In the Finder window that opens navigate to Contents > Resources > AddOns. Here you will see the icon for the pack
  3. Double click on the pack icon you are missing. You may get a popup telling you an update is available, go ahead and update. If you are further prompted to update Permissions then go ahead and enter your password when prompted (this is a macOS security feature).
  4. After the update you will probably get the Unknown Error message again. Just click ok.
  5. Now right click on the add-on pack and select Make Alias. Drag the alias file you have just created into the Applications > Electronic Arts > The Sims 3 folder so the folder now has the base game and all your EP/SP shortcuts (aliases) in it. Delete the alias from the file name so it just has the name of the EP/SP.
  6. Attempt to launch the game through the shortcut you just added to the Sims 3 Applications folder. If you are still getting the Unknown Error message then you MUST follow Corey_0414’s instructions which fixes the issue here.
  7. Repeat the above for every EP/SP that has not installed into the Sims 3 Applications folder.

 

Advertisements

24 thoughts on “Sims 3 Packs not showing as installed – workaround

  1. Thank you so much for this post. It was a relief to read such a simple and straightforward set of instructions. I hadn’t played in a while (and never on my new computer, hence the download issues), but now I have a fun way to relieve stress over the holidays.

    Like

  2. THANK YOU SO MUCH!

    Followed all steps + the linked fix and my game is working (problem for me was Ambitions)! You don’t know how happy I am! Things weren’t looking good at first and I had convinced myself that I would never play the Sims 3 again, but this fix worked. 🙂

    Thank you again!

    Like

  3. I tried this for ambitions and it worked! However, I also tried it with Late Night but then it doesn’t. I did every step untill 5. I now have ts3, word adventures, ambitions and late night. So I don’t know where to place the Late Night file like shown Corey_0414’s instructions, since it’s the newest pack. Do you have any suggestions? I thought of trying to just install the other packs (I have al expansions exept for show time so I’m working down the list) any maybe then trying Corey_0414’s instructions, but I don’t know if that will mess up my entire game (since it’s not in the right order of packs). PLEASE HELP

    -Liz

    Like

    1. Install everything and then make sure that ITF has all the expansion and stuff pack files in it, as per Corey’s instructions. Follow the instructions on this page for getting the problematic packs to show up in the launcher (LN, Ambitions, FL, OL)

      Like

    2. UPDATE

      I completely uninstalled Late Night, so the game worked again (with world adv. and amb.). I then tried to download and install Generations and the game icon showed up (yay), but when I try to open the launcher I get ‘unknown error occurred’ again! I just don’t understand..

      Like

        1. Thanks for the link. That’s a rehashed version of corey’s video. You don’t need Origin open at all once you’ve downloaded the game. Close it so not to waste precious resources on your Mac 😊

          Like

  4. I followed the instructions and when i launched the game it came up with a message saying unofficial game and that i needed to update the game. How can i update the game?

    Like

  5. This fixed the problem last night, but the add-on didn’t stay in the folder for some reason (I didn’t realize it until this morning, though). I tried to go back and re-do the whole process to fix it, but my Mac won’t even let me right-click on The Sims 3 in order to Show Package Contents anymore (meaning I can’t even do the first step anymore). What do I do now?

    Like

      1. When I go to Applications>Electronic Arts> The Sims 3, The Sims 3 pops up as a folder and there is no icon, neither on the folder as a whole or in any of the folder contents (I’m assuming this is where you’re asking me to go). The only options when I right-click on the folder are to rename, move to trash, duplicate, and then quick look. Otherwise, the icon I use to open the actual game doesn’t let me right-click; it automatically tries to launch the game and then gives me the Unknown Error occurred message

        Like

        1. UPDATE: I was able to open The Sims 3 in Finder and I was able to relocate the alias I had created (The problem was Late Night). I was able to open the launcher for Late Night, and I think* this should fix the problem. If something else comes up, I’ll be in touch. Thank you!

          Like

  6. I thought that this was my problem, but the fixes really didn’t do anything since it was already showing up in most places. Master Suite stuff is installed, the icon shows up in the applications folder, the folder for the game is in the right spot in the launch game, but it doesn’t show as installed in the launcher. I have used the fixes on other titles, and it worked perfectly for those (so I don’t think it’s me not following instructions correctly), but I’m struggling this time. I tried copying and replacing the folder in the launch game in case something had corrupted between them or something, tried to make a new alias folder icon, but when I try to launch through Master Suite I get the unknown error. The game still launches from other icons though. I have no idea what to do, as all the files and icons were already in the right places and everything seems to be fine, it just doesn’t show on the launcher that I have it and I get the error message from trying to launch it. Any thought? Should I just do an uninstall and see what happens when I reinstall it, or is it a known issue I didn’t see while searching through the site?
    Thanks in advance for reading this, and for any help you may have! And for all you do in general, you are truly a lifesaver when it comes to trying to get my mac to play this game.

    Like

Leave a reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.