Mac OS X Lion, the Sims 3 and the latest patch.

So EA have now released a patch to fix the graphics card problem for users with the NVIDIA GeForce 9400M and NVIDIA GeForce 320M (no mention of the Intel 3000 unfortunately). The patch brings the base game up to 1.25.

I installed the patch and immediately my game was unplayable. The patch couldn’t even complete the install. This was the error log:

Examining File : /Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/Packs/TS3EP01/TS3EP01.exe -> SHA1 Error
Examining File : /Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/Packs/TS3EP02/TS3EP02.exe -> SHA1 Error
Examining File : /Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/Packs/TS3EP03/TS3EP03.exe -> SHA1 Error
Examining File : /Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/Packs/TS3EP04/TS3EP04.exe -> SHA1 Error
Examining File : /Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/Packs/TS3SP01/TS3SP01.exe -> SHA1 Error
Examining File : /Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/Packs/TS3SP02/TS3SP02.exe -> SHA1 Error
Examining File : /Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/Packs/TS3SP03/TS3SP03.exe -> SHA1 Error
Yeah, whatever that means. All I can make out is a problem with World Adventures, Ambitions, Late Night, Generations, High End Loft, Fast Lane and Outdoor Living.
So I completely uninstalled, including trashing the Transgaming Preference files in the Library Folder, and reinstalled in the release date order, patching after each install.
And it now works beautifully. Except for not being able to take screenshots which is a huge problem because I need my screenshots for my upload pictures. So I will have to build in the Mac OS, export the house into the Windows partition, take pictures, then upload. Not impressed.
Anyway, the good news is that the patch does appear to fix the graphics issue. I played for about half an hour using my integrated 9400M card and it played really smoothly.
So if you want to be able to play your game and are willing to completely uninstall and reinstall, again, then this patch is for you 🙂
My specs:
15″ Mid 2009 MacBook Pro
Mac OS X Lion 10.7.1
NVIDIA GeForce 9400M 256 and GeForce 9600M GT 256
8Gb RAM
Advertisements

33 thoughts on “Mac OS X Lion, the Sims 3 and the latest patch.

  1. BluebellFlora Post author

    They do when you reinstall, that’s normal, make sure you patch after each EP and SP. After I installed the Base Game there were 2 patches, one took me to 1.22 then the second updated to 1.25. Good luck!

    Like

    Reply
    1. BluebellFlora Post author

      Go to Library > Preferences and delete every file that has Transgaming in the name. They will start with com.transgaming…. If you have Lion installed your Library folder is hidden, make sure your menu bar at the top is saying Finder then hold down the option key (alt) and click on Go. Your Library folder will appear in the drop down menu. If there is a folder called “The Sims 3 Preferences” in there then delete that too. It also wouldn’t hurt to delete the “Cider Preferences” folder too.

      Like

      Reply
  2. Mx!pa

    I just did it! Thanks, Bluebell!! I’m running Lion, in a MacBook Pro 2010… I really want to play the sims… I’ll reinstall ts3 right now!

    Like

    Reply
  3. BluebellFlora Post author

    Reckon it must be something to do with Town Life. Someone reported that they managed to reinstall fine until Town Life then it went schizo again. I dunno, I give up with EA, lazy wankers. 😉

    Like

    Reply
  4. whtrbtsims

    Hi, Bluebellflora.
    I did the uninstall as you described. I installed the base game, patched up to 1.25. The installed WA , HELS, AMB, FLS, LN, and OLS, patching along the way. I noticed that Amb and WA didn’t install right, meaning that their mini tiles on the launcher were missing. Additionally, Twinbrook was not on the list of available towns. I then tried to test a sim in Bridgeport, and noticed that he didn’t have the ambitions lifetime wishes (fireman, stylin’, etc)

    So I went to uninstall and noticed that in the list of EPs and SPs that WA and AMB were missing.

    I uninstalled base game and all EP in one fell swoop and tried again. This time I stopped at WA. I saw that now the Base game tile was missing! Also I checked the uninstaller and WA was not there again.

    Any ideas? Why is this happening?

    Like

    Reply
    1. BluebellFlora Post author

      Oh god that sounds like a nightmare! I have no idea why it’s happening, especially if you’re getting rid of all the Transgaming files which often cause the problems. I think the only solution would be to keep trying, patching along the way. I opened the launcher after each install but didn’t start the game until after Generations, then I installed Town Life. Hope you get it sorted soon 😦

      Like

      Reply
  5. BluebellFlora Post author

    I don’t know, you must have the 15″ or 17″ so you therefore have a dedicated graphics card, it should be fine upgraded to Lion. But this being an EA game, you just won’t know until you try 😦 I’m running Lion on my 2009 15″ MBP and it’s running really well, fully patched up to date. But it seems I’m one of the lucky few. At the end of the day, do you want to install a great new OS, or do you want a crappy EA game to rule your computer? Sorry I can’t help more, there seems to be no definitive reason for this crap.

    Like

    Reply
  6. whtrbtsims

    I have the 17″ MBP. I decided to buy Lion last night, which was probably a mistake because now my Quicken 2007 won’t work. 😦

    Anyway, the Sims 3 installed ok. I did the clean install–again. I installed base game, patched to 1.25, WA, patched, and HELs and patched. I decided to check the uninstaller. However, now the uninstaller won’t open because “it may be damaged or incomplete”! Can you believe this?

    I am at a loss with this game. I did call tech support yesterday before I got Lion and got elevated to tier 3, which means that someone promises to email you later. They had no answers for me. I will have to call them back today and see what they say about this.

    Can you check your Uninstaller since you have Lion and let me know if it at least opens?

    Thanks for everything.

    Like

    Reply
  7. whtrbtsims

    I posted pics on that thread you were maintaining in the Mac discussion on the official forum. I have been on the phone with the Tech Support team and have been elevated to tier 3 support. So far, they have no answers. I can’t even get the game installed properly and can’t play. It either won’t uninstall at all or will not recognize the expansions. As you know, if anything is screwed up with Sims 3, NOTHING will work. All the stars and the sims gods have to be aligned to get this game working. Otherwise, you’re screwed.

    Anyway, I am very depressed about this. Tier 3 do not speak to you directly, either. You have to wait for them to contact you via email, which is like a hope and prayer. I have a good mind to ask for all my money back.

    Like

    Reply

Leave a reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s