The Sims 4 on a Mac

As we all know The Sims 4 isn’t yet available for OS X. Maybe it never will be? So instead of crying and stamping feet, how about being a little bit proactive or give up and move on? The only way you will be able to run TS4 on your Mac at the moment is to either Boot Camp your Mac or install a virtual machine with Windows.

There is NOTHING wrong with installing Windows on your Mac. Any Mac with an Intel processor (basically any made in the last 7 years or so) can run Windows happily. I’m afraid I have no time for petulant Mac users who refuse to “pollute” their darling Macs with Windows. Instead look at it this way – how amazing and cool is it that your “darling” Mac CAN run Windows? And, in my experience, more smoothly and trouble free than most PCs. How cool is it that virtually no software is out of your reach? That you can run virtually anything on your Mac? Pretty damn cool I think.

So if you’d like to Boot Camp your Mac but are a bit scared, rest assured it is ridiculously easy:

How to install Windows using Boot Camp (with screenshots)

Or if you’d like to install Windows in a virtual machine so you can run it at the same time as OS X I’d recommend Parallels. I’ve used both VMware and Parallels in the past, specifically for CAW, and I found Parallels to be a lot easier, more user friendly, and more frequently updated than VMware. But that’s just my experience.

In the meantime, if you are playing, or attempting to play The Sims 4 on your Mac in Windows, please head over to this thread I’ve started on the officials so everyone can share their experiences and help each other. It seems like so far people are able to play relatively problem free 🙂

Advertisements

8 thoughts on “The Sims 4 on a Mac

  1. juliazitronenzwitter

    Hey 🙂
    Sadly I’ve some problems with Sims 4 on my Boot Camp. Sims 3, Sims 2 and Anno ran perfectly fine on Boot Camp, but Sims 4 will crash just out of the blue. 😦 Do you have any ideas how I could fix this?

    Like

    Reply
      1. juliazitronenzwitter

        Hey thanks for the reply. Now it’s running (after I patched it again?)… ugh that’s so EA 😀 But Yeah, just wanted to let you know that it’s working now…

        Like

        Reply

Leave a reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s