Mac Sims 4 shadow bug

We have a new Mac specific bug that’s popped up since the November patch, game version 1.47.49.1220.

If you play with laptop mode off you will see a weird straight line shadow following your Sim around when they are inside:

A workaround at the moment is to enable laptop mode in your game. You could also go into the GraphicsRules.sgr file and change the RenderShadowsEnabled value to false but enabling laptop mode is a lot quicker and easier. You may get the awful pink floors bug back though so you decide which is worse!

We have a thread over at AHQ so please do take a minute to press the Me Too button so EA are aware of how widespread it is. If you have a minute I’d really appreciate it if you could please post your Mac model too and version of macOS – https://answers.ea.com/t5/Bug-Reports/Mac-Sims-cast-weird-shadows/m-p/7178640

Advertisements

Sims 4 CAS cursor glitch on Mac

This has been around for ages and doesn’t seem to be going away anytime soon. When trying to use CAS the cursor is glitching and displaying one or more of the following symptoms:

  • When editing a body part the cursor will not ‘let go’ of the part to stop editing
  • Moving your cursor over the screen will randomly grab a body part for editing
  • Rotating the Sim is not possible unless using the keyboard arrow keys


(thanks to 13Vader for the video)

At the moment there is no solution or workaround although some users have reported that it resolves itself after a game update. We have a thread at AHQ collecting information and it does seem to be affecting lower spec. Macs so lowering your in-game graphics options may help. Please post in the thread if you are experiencing this or if you have found a fix, or leave a comment below.

Sims 4 screen flickering

This problem has been around for a while and affected some Mac users but not all.

Symptom
When you play your game the screen will flicker and changing certain graphics options in-game doesn’t fix it.

Cause
Edge Smoothing settings in the Graphics Options in-game.

Solution
Play around with the Edge Smoothing settings in the Graphics Options menu. Try turning it off if you have it on or lowering it if you have it on high. Also try raising it if you have it on low.

Thanks to the wonderful people who have confirmed the issue and solution over on this thread at AHQ.