Running 10.7.5 Lion or 10.8.5 Mountain Lion? Please read this…

Origin now requires 10.9 Mavericks or later to run on a Mac. The Sims 4 requires 10.7.5 Lion or later. The Sims 4 will not run without Origin so technically the Sims 4 will now not run on a Mac unless it is using 10.9 or later. If you are running Lion or Mountain Lion then please take a moment to post in this thread over on the official forums.

Thanks 🙂

Advertisements